网络安全
    作者:陈杰

    爆百度编辑器ueditor语法过期错误

         [ 中关村在线 原创 ] 暂无评论

      据有关人士发现,在百度的开源编辑其中ueditor/third-party/jquery-1.10.2.min.js 这个文件的头部注释部分出现了过时的语句错误。

    爆百度编辑器ueditor语法过期错误
    百度编辑器

      /*! jQuery v1.10.2 | (c) 2005, 2013 jQuery Foundation, Inc. | jquery.org/license

      //@ sourceMappingURL=jquery-1.10.2.min.map

      */

      语法的"@"符号已被弃用

      //@ 已经过时需要替代成//#

      其中ueditor/ueditor.all.js 仍然出现并且沿用了方法过期语句

      getPreventDefault()需要使用 defaultPrevented 替代。

      getAttributeNode()需要使用getAttribute() 替代。

      removeAttributeNode()需要使用removeAttribute() 替代。

      getAttributeNode()需要使用getAttribute() 替代。

      removeAttributeNode()需要使用removeAttribute() 替代。

      错误过期的语句会造成浏览网站的时候,浏览器报错问题发生冲突以及一些隐性问题,原以为百度不会出现这么低级的过期语法错误问题,笔者也是偶然在开发嵌入百度编辑器ueditor时候发现报错的,其实也不是什么大问题,但是也希望可以尽快更新,避免给众多开发者造成安全隐患。

    周关注排行榜

    防火墙UTM上网行为防毒墙

    文章推荐

    互动沙龙

    相关内容 网友评论 返回首页
    专家咨询