网络安全
    作者:郑伟

    Samba曝出7年漏洞 1行代码即可远程攻击

         [ 中关村在线 原创 ] 暂无评论

      目前安全研究人员发布公告称,发现Samba存在一个长达7年的漏洞,攻击者仅需一行程序代码就能远端执行恶意攻击。而2010年3月发行的Samba 3.5.0以上的版本都受这个编号为CVE-2017-7494的漏洞影响。所幸该漏洞已经被紧急修复了。

    Samba曝出7年漏洞 1行代码即可远程攻击
    Samba曝出隐藏7年的漏洞

      据悉,代号为HD Moore的安全研究人员在Twitter上指出,发现的Samba漏洞与此前引发WannaCry蠕虫肆虐的“永恒之蓝”有几分相似,都属于文件共享服务漏洞。不过所影响的系统不是Windows,而是Unix或Linux系统。最关键的是,骇客只要一行程序代码就能发动攻击。

    Samba曝出7年漏洞 1行代码即可远程攻击
    骇客只要上述一行程序代码就能发动攻击

      由于Samba是让Unix/Linux系统及Windows系统间进行资源共享的服务,可让Linux、Mac OS用户可以通过SMB/CIFS协议存取Windows电脑上的文件。攻击者一旦传送具写入权限的共享文件,利用已知的路径上传Unix/Linux服务器,再由服务器执行恶意程序,可向开启文件及打印共享的445端口的受害电脑发动攻击。

      然而不同于“永恒之蓝”,Samba漏洞攻击的防御更具有难度,因为这些系统没有统一的补丁程序分发机制,而且相关设备无法由使用者自行在OS层上打补丁。由此,上述问题或为企业网络带来更大的风险。

      在调查中,安全研究人员通过网络扫描发现目前有超过10.4万台连网的电脑,正使用有漏洞的Samba版本并开放了445端口,其中有90%尚没有现成的补丁推出。此外,139端口也受到Samba漏洞影响,涉及设备达11万台,其中91%的更是已不受支持的旧版本。因此,相关企业IT人员急需关注。

      虽然漏洞攻击尚未大规模爆发,但是研究人员已发现开始有概念验证攻击程序在Twitter上蔓延,而且也看到用于检测系统漏洞的工具metasploit模块开始大量流通。

      目前,Samba 4.6.4、4.5.10及4.4.14版已完成修补并已发布,建议IT管理员和用户尽快安装。

    标签:防火墙

    周关注排行榜

    防火墙UTM上网行为防毒墙

    文章推荐

    互动沙龙

    相关内容 网友评论 返回首页
    专家咨询