网络安全
    作者:郑伟

    蓝牙曝出高危漏洞 你该怎么办?

         [ 中关村在线 原创 ] 暂无评论

      据国外安全公司Armis爆料,其实验室研究人员近日发现了一项基于蓝牙漏洞而进行的攻击手法,被称为“BlueBorne”。BlueBorne能够利用蓝牙协议栈中发现的8个零日漏洞,对运行Android、iOS、Windows以及Linux等操作系统的移动、桌面、IoT(物联网)等设备发起攻击,危害较大。

    蓝牙曝出高危漏洞 你该怎么办?
    蓝牙曝出高危漏洞

      下面是研究人员展示的对Google Pixel手机的攻击视频,受害者全程无感。。。

      此次蓝牙漏洞列表:

      ·Linux内核远程代码执行漏洞 - CVE-2017-1000251

      ·Linux蓝牙堆栈(BlueZ)信息泄漏漏洞 - CVE-2017-1000250

      ·Android信息泄漏漏洞 - CVE-2017-0785

      ·Android远程代码执行漏洞#1 - CVE-2017-0781

      ·Android远程代码执行漏洞#2 - CVE-2017-0782

      ·Android中Bluetooth Pineapple逻辑缺陷 - CVE-2017-0783

      ·Windows中Bluetooth Pineapple逻辑缺陷 - CVE-2017-8628

      ·苹果低耗音频协议远程代码执行漏洞 - CVE-2017-14315

      蓝牙高危漏洞的影响

      在上述确定的8个零日漏洞中,有4个是高危漏洞,致使利用BlueBorne攻击只需目标设备的蓝牙处于开启状态即可,不仅无需配对,而且目标设备不用设置为可发现模式,具有一定程度的隐秘性。

      根据预估,此次曝出的蓝牙高危漏洞覆盖多达82亿台装有蓝牙模块的终端设备,包括智能手机、平板电脑、笔记本或台式机、电视、汽车、医疗器材、物联网设备等等。由于目前蓝牙对于所有操作系统拥有较高的权限,因此危害性不容小觑。而利用BlueBorne攻击可以远程控制设备,渗透企业内网获取数据,感染相邻终端传播恶意软件,或进行中间人攻击。

      在漏洞曝出后,笔者采访到国内蓝牙协议栈IP提供商艾威梯互联的专家朱勇先生,据其指出,虽然此次蓝牙漏洞事件影响广泛,但蓝牙协议本身并不存在漏洞,问题多是出现在各个操作系统对蓝牙协议栈的接口实现上。BlueBorne攻击也是利用到缓存溢出/堆栈溢出等情况。如果蓝牙相关设备商采用了独立的内存分配机制,将蓝牙协议栈使用的内存与操作系统核心内存物理隔离,那么被攻破的可能性就会非常小了。

          此外,由于蓝牙仍属于短距离无线通信技术,因此,朱勇认为攻击者必须要在近距离范围内携带相应的攻击设备(如笔记本、蓝牙射频设备等),才能发起攻击,所以要想展开全球性的蠕虫攻击怕是要满足更多的客观条件。不过,针对一些基于蓝牙应用的特定物联网场景仍需加强相应的安全防护。

      该如何防范?

      那么对于一般大众来说,该如何防止遭受到BlueBorne攻击呢?

    蓝牙曝出高危漏洞 你该怎么办?
    如何防止遭受到BlueBorne攻击

          目前苹果、Google、微软都已经发布了漏洞补丁,终端用户应尽快安装升级自己的设备固件。对于暂时无法获得相应补丁的用户来说,则应尽快关闭蓝牙选项,防止曝露在风险之中。

    周关注排行榜

    防火墙UTM上网行为防毒墙

    文章推荐

    互动沙龙

    相关内容 网友评论 返回首页
    专家咨询